Bug 993 - MODTRAN paths containing spaces don't work
Summary: MODTRAN paths containing spaces don't work
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: Atmosphere (show other bugs)
Version: 4.5.0-beta
Hardware: Other Other
: P5 normal
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2013-02-18 10:10 EST by Scott D. Brown
Modified: 2013-02-26 08:35 EST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott D. Brown 2013-02-18 10:10:03 EST
If your MODTRAN path contains spaces (common on Windows where MODTRAN might be installed in "C:\Program Files"), then DIRSIG cannot launch MODTRAN from either a
"Classic" (make_adb) or "Threshold" atmosphere configuration.
Comment 1 Scott D. Brown 2013-02-26 08:35:27 EST
The problem is that QProcess::execute() interpretes a path that contains spaces as the program name followed by arguments.  So it attempts to run the first "token" of the path (the part before the first space)  as the program and the remaining part as arguments.  Hence a path like "C:\Program Files\Modtran522\modtran.exe" results in DIRSIG (via QProcess) trying to run a program called "C:\Program" with the argument "Files\Modtran522\modtran.exe".

The solution was to simply wrap the path with double-quotes.