Bug 904 - Multi-level INCLUDE_FILE doesn't work with ODB files
Summary: Multi-level INCLUDE_FILE doesn't work with ODB files
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: General/Performance (show other bugs)
Version: 4.4.2-beta
Hardware: All All
: P5 blocker
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2011-12-02 13:10 EST by Michael Gartley
Modified: 2011-12-05 10:38 EST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Gartley 2011-12-02 13:10:35 EST
on SVN version of MegaScene2, all .sim files are seg faulting, whereas 4.4.1 runs fine.. what's different?

DIRSIG4
Release: 4.4.2 (r9728)
Build Date: Nov 18 2011 11:57:34
Copyright 2005-2011 Rochester Institute of Technology

Initializing generic platform model: 
    Location/Orientation history filename = /cis/staff/mxgpci/BigScenes/MegaScene2/shots/nadir_rgb/./nadir.ppd
    This file contained 1 location/orientation records.
    Checking task time windows against available position data ... done.
        Platform is static and independent of capture times

Initializing imaging platform:
    Master clock rate = 1 [Hz]
Initializing static instrument mount ... done.
Initializing RGB Array:
    Using simple capture method
        Initializing spectral response ... done.
        Initializing spatial response ... done.

Reading in object database file: megascene2.odb

Segmentation fault
Comment 1 Scott D. Brown 2011-12-05 09:15:28 EST
I will look into this ASAP this AM.
Comment 2 Scott D. Brown 2011-12-05 09:17:32 EST
Yep, I can reproduce this.  I will see what's up.
Comment 3 Scott D. Brown 2011-12-05 09:25:59 EST
Something is going bad when it tries to read the "terrain/terrain_northwest.gdb" file. The file looks OK, and the old GDB reader in Bulldozer reads it OK.
Comment 4 Scott D. Brown 2011-12-05 09:47:38 EST
Correction, it seems to be something related to multi-level ODB includes.
Comment 5 Scott D. Brown 2011-12-05 10:38:54 EST
The problem was that when we the ODB reader sees an INCLUDE_FILE directive, it wasn't telling the reader to NOT flatten the hierarchy of the included geometry.  However, the ODB reader assumes that it would be flattened.  This worked fine when there was only one level of INCLUDE_FILE, but not when there was multiple.