Bug 881 - Space-based objects disappear for earth-based platform
Summary: Space-based objects disappear for earth-based platform
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: Platform (show other bugs)
Version: 4.4.1-release
Hardware: Intel x86 Windows 32-bit
: P5 normal
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2011-05-31 14:52 EDT by Matt Baran
Modified: 2011-10-18 13:27 EDT (History)
2 users (show)

See Also:


Attachments
Modified up-looking ODB file. (415 bytes, application/vnd.sun.xml.base)
2011-05-31 14:52 EDT, Matt Baran
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Baran 2011-05-31 14:52:16 EDT
Created attachment 242 [details]
Modified up-looking ODB file.

I am having trouble generating an up-looking scene to observe objects in low earth orbit from an earth-based sensor.  It appears that any object above the 100km mark is absent from the final imagery.  The preview image does show the space based object though.

To reproduce the issue, use the "uplook.sim" scene from the "SensorPosition1" demo with the attached ODB file.  The new ODB simply moves the aircraft to an altitude of 101000 meters.

-Matt


Matthew S. Baran
msb236@psu.edu
Comment 1 Scott D. Brown 2011-05-31 18:50:04 EDT
I just want to verify that this was with the 4.4.1 release build?

Also, the Ssa1 demo appears to be a ground based system (scene locations are all 0 in the Z dimension) looking at a space based object.  Can you maybe check if that one works?
Comment 2 Matt Baran 2011-06-01 09:49:24 EDT
You are correct that this is for the 4.4.1 release.

I am able to run the ssa1 demo and see objects in the image.

After adding the advanced options from ssa1 into the modified SensorPosition1 demo to expand the atmospheric sphere, I am able to see the object at 101000 meters.  I think my problem is solved, thanks.

-Matt
Comment 3 Scott D. Brown 2011-09-16 11:47:17 EDT
Mike Gartley
Comment 4 Scott D. Brown 2011-09-16 11:48:58 EDT
Mike Gartley also reported this and assembled a demonstration case.  The problem was isolated to the radiometry solver associated with the atmosphere which would set the transmission to leave the atmosphere to 0.

A patch has been checked in and I am waiting for Mike Gartley to bless it.
Comment 5 Scott D. Brown 2011-10-18 13:27:03 EDT
Looks like we have this one sorted out.  The fixes will appear in the 4.4.2 release.