Bug 877 - Mod5.2.0.0 creates make_adb error on MAC
Summary: Mod5.2.0.0 creates make_adb error on MAC
Status: RESOLVED INVALID
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: make_adb (show other bugs)
Version: 4.4.1-beta
Hardware: Macintosh PPC MacOS 10.6
: P5 normal
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2011-03-09 18:30 EST by Jeff Dank
Modified: 2011-05-06 16:51 EDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Dank 2011-03-09 18:30:35 EST
I'm trying to generate an adb... and I'm getting this error:

make_adb: OPEN ERROR
    could not open MODTRAN output file!
    Filename = tape7.scn
    Exiting 



The only thing that is created in the sim directory is are these files:

modtran.log - blank
tape5 - I can run this using Mod5.2.0.0 by itself 
*.lock file

there's no tape6 file generated

this error is happening even on the demos that come w/ DIRSIG both sim files and cfg files
Comment 1 Scott D. Brown 2011-03-09 18:35:12 EST
A few things to check:
* I suspect this is actually with 4.4.0 with an Intel Mac
* Run "make_adb -config" and verify all the paths it reports
* Always check the "modtran.log" file for any details about a MODTRAN crash when called from DIRSIG
* Does it seem like MODTRAN is being run?  Meaning, can you witness the MODTRAN process running in a "ps" or does "make_adb" at least pause like MODTRAN is being run?
Comment 2 Jeff Dank 2011-03-09 19:49:21 EST
This is with the 4.4.1 beta version...I'm not sure if it's intel or ppc. 

When I run make_adb -config all of the paths are correct.



I did notice one thing...I tried running using threshold atmosphere and it gave me an error:
dyld: Library not loaded: ./libg fortran.3.dylib

Reason: image not found
Trace/BPT trap

I notice I get this error when I try to run the modtran executable from a directory other than the one where it's located:

if in /user/local/ and I type /models/mod5/Mod.exe modtran doesnt run, but if I'm in /models/mod5/ and type Mod.exe modtran will run fine.

I don't know if this has anything to do with make_adb crashing or not.
Comment 3 Jeff Dank 2011-03-09 19:52:49 EST
Also, I can't see modtran being run...it crashes too quickly
Comment 4 Jeff Dank 2011-03-09 20:10:15 EST
Ok...So I moved the "libgfortran.3.dylib" file into the directory where my sim file is located...and make_adb ran fine.

I don't know if you want to consider that a "fixed" bug, but I changed the importance now that I can at least work it doing that :)
Comment 5 Scott D. Brown 2011-03-10 08:42:07 EST
So the problem is that you need to update your dynamic library path.  On most *NIX, that is the LD_LIBRARY_PATH environment variable.  On OSX, they use a slightly different share library format (that supports multiple processor types, frameworks, etc.) and the environment variable is DYLD_LIBRARY_PATH.  Just set that to point to the directory with the "fortran.3.dylib" file in it.

Or, Dave and you could try to recompile MODTRAN with static libraries.

Can you verify that the "modtran.log" file had the same error in it when make_adb was run?
Comment 6 Jeff Dank 2011-03-10 12:32:07 EST
There's nothing in the modtran.log file when make_adb crashes with it's initial error. The file is 0b.
Comment 7 Scott D. Brown 2011-05-06 16:51:44 EDT
This "bug" turned out to be a problem with the user's computing environment. DIRSIG cannot "catch" the message from the operating system that it couldn't start the program.

We are updating the install docs to make sure people know that MODTRAN must be able to run from anywhere.