Bug 700 - Mov file scaling does not seem to work right
Summary: Mov file scaling does not seem to work right
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: Geometry (show other bugs)
Version: 4.2.2-release
Hardware: All All
: P3 normal
Assignee: Niek Sanders
URL:
Depends on:
Blocks:
 
Reported: 2009-05-01 11:15 EDT by Niek Sanders
Modified: 2011-10-18 15:00 EDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Niek Sanders 2009-05-01 11:15:41 EDT
I just confirmed that scaling in the movement file does not work as expected.

Changes the demos/Movement1 mov file to have no rotation, but a -0.1 x-scale and a +0.1 y-scale for each step.  Generated envi images don't look right, though some scaling is happening.
Comment 1 Adam Goodenough 2011-10-18 15:00:22 EDT
This was caused by a simple typo:

    newScl[ 0 ] = aScl[ 0 ] + ( bScl[ 0 ] - aScl[ 0 ] ) * shift;
    newScl[ 1 ] = aScl[ 0 ] + ( bScl[ 1 ] - aScl[ 1 ] ) * shift;
    newScl[ 2 ] = aScl[ 0 ] + ( bScl[ 2 ] - aScl[ 2 ] ) * shift;

(note the first aScl in each calculation). It is now fixed.