Bug 375 - Error in generating image of Microscene
Summary: Error in generating image of Microscene
Alias: None
Product: MicroScene1
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Intel x86 Linux 32-bit
: P3 normal
Assignee: Niek Sanders
Depends on:
Reported: 2006-04-01 17:07 EST by Ryan Hruska
Modified: 2006-04-06 11:01 EDT (History)
0 users

See Also:

scene configuration (2.74 KB, text/plain)
2006-04-03 10:58 EDT, Ryan Hruska
PanelScene cfg file (5.68 KB, text/plain)
2006-04-04 10:43 EDT, Ryan Hruska
cfg file with platform update (5.69 KB, text/plain)
2006-04-04 14:57 EDT, Ryan Hruska
Error file associated with core dump (680 bytes, text/plain)
2006-04-04 14:58 EDT, Ryan Hruska
Output file associated with run (16.30 KB, text/plain)
2006-04-04 14:59 EDT, Ryan Hruska

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Hruska 2006-04-01 17:07:28 EST
When generating an image of Microscene1 I received the following error:

   Facet vertexes from a line!(discarded)
   Line number = 1216249
   Filename = "HumveeWithSupports.gdb"
dirsig: CDproblem.nw:405: void CDProblem::createsolution(CDSolution&, bool): Assertion 'hitList.count() != 0' failed.
Comment 1 Niek Sanders 2006-04-02 12:14:06 EDT
Did you use one of the .cfg files distributed with microscene or did you roll or own?  If the latter, would it be possible to attach your cfg to this bug report?

Also, which version of DIRSIG4 are you using?
Comment 2 Ryan Hruska 2006-04-03 10:58:20 EDT
Created attachment 93 [details]
scene configuration
Comment 3 Ryan Hruska 2006-04-03 10:59:19 EDT
I am using version 4.
Comment 4 Ryan Hruska 2006-04-03 11:34:26 EDT
That is version 4.0.6. Also I have tried to load some of the cfg files that were provided for this scene but they cause cfg_edit to crash (ADB_FILENAME varible was never set!). I'm using verison 3.6.4 of cfg_edit, could this be the problem. When installing the distribution of 4, a version 4 of cfg_edit was not included.
Comment 5 Ryan Hruska 2006-04-04 10:43:07 EDT
Created attachment 94 [details]
PanelScene cfg file
Comment 6 Ryan Hruska 2006-04-04 10:43:30 EDT
I was able to get DIRSIG to run, using one of the provided cfg files after editing it based on previous posts. However, the image returned is all null values. The only difference between the post and what I did was change the material IDs to from 501 to 11 and 502 to 10, instead of adding these materials. I have attached the new cfg file. 
Comment 7 Niek Sanders 2006-04-04 11:25:24 EDT
Your sensor is floating way out in space; you won't be hitting any geometry out there.  Try changing your position information to:

        TARGET_LOCATION = 115, 90, 0
        PLATFORM_LOCATION = 115, 90, 300

The assertion is triggering because DIRSIG isn't hitting the skydome (the geometry for the atmosphere).  The next release of DIRSIG4 will include a more user-friendly error message.

Comment 8 Niek Sanders 2006-04-04 13:41:27 EDT
Error message now displays in CVS version of DIRSIG4:
    CDProblem.nw v1.38
Comment 9 Niek Sanders 2006-04-04 13:57:37 EDT

Are you still having problems after tweaking the platform/target or can I close this bug?

- Niek
Comment 10 Ryan Hruska 2006-04-04 14:32:57 EDT

I ran the simulation again with the new sensor position and got the original error. Any thoughts?

Comment 11 Niek Sanders 2006-04-04 14:37:49 EDT
Could you post your updated cfg?  I'll see if I can reproduce the assertion again.  Right now, things are working for me if I use the new platform/location.
Comment 12 Ryan Hruska 2006-04-04 14:57:01 EDT
Created attachment 95 [details]
cfg file with platform update
Comment 13 Ryan Hruska 2006-04-04 14:58:20 EDT
Created attachment 96 [details]
Error file associated with core dump
Comment 14 Ryan Hruska 2006-04-04 14:59:09 EDT
Created attachment 97 [details]
Output file associated with run
Comment 15 Ryan Hruska 2006-04-04 15:00:07 EDT

Have post the cfg, error, and output file. 

Thanks for your help,

Comment 16 Ryan Hruska 2006-04-04 15:29:24 EDT

I ran make_adb again with the new sensor location and then ran dirsig, I no longer get the above error, however, the core is dumped after current platform location is written.

Comment 17 Niek Sanders 2006-04-04 16:34:44 EDT
With your latest config file things are running fine on my development box (I had to fix the paths for my installation, including the MAPS_PATH).  I'll give it a try on our Sun and Linux machines tonight.
Comment 18 Ryan Hruska 2006-04-06 10:54:13 EDT
Niek, I was able to get Microscene to run using UTM coordinates, removing the panels from the scene, and running it on our older sun box. I guess I'm unclear as to why this worked, the same cfg still does not work on our new linux cluster. If you have any questions let me know?
Comment 19 Niek Sanders 2006-04-06 11:01:39 EDT
I'll hopefully be able to do a few runs on our linux boxes tomorrow.  I'm a bit swamped right now, so it may take I while before I can work on this again.