Bug 1304 - FlexMotion engines do not correctly interpolate with a single entry in the supplied data.
Summary: FlexMotion engines do not correctly interpolate with a single entry in the su...
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: Motion (show other bugs)
Version: 4.7.5-release
Hardware: All All
: P5 normal
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2020-10-19 14:14 EDT by Scott D. Brown
Modified: 2020-10-19 14:26 EDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott D. Brown 2020-10-19 14:14:12 EDT
If you supply a single data entry to the waypoint location engine, or the EulerAngle or Quaternion orientation engines, temporal interpolations will be sometimes address out of bounds memory. This will result in execution failures (segfaults on Linux/MacOS and unexpected exits on Windows).
Comment 1 Scott D. Brown 2020-10-19 14:14:50 EDT
This bug was discovered as the root cause in bug #1300.