Bug 1228 - Translating / Rotating Atmospherics Via Glist Broken
Summary: Translating / Rotating Atmospherics Via Glist Broken
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: General/Performance (show other bugs)
Version: 4.7.1-release
Hardware: Intel x86-64 Linux 64-bit
: P5 normal
Assignee: Adam Goodenough
URL:
Depends on:
Blocks:
 
Reported: 2016-08-12 17:56 EDT by Jeff Dank
Modified: 2016-09-14 09:52 EDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Dank 2016-08-12 17:56:11 EDT
The only way to translate the atmospherics is via the insert point in the material entry file. The glist translation / rotation either does nothing... or does something unexpected (like moving or rotating an unknown amount)

I'm either attaching or emailing the files needed to reproduce the bug.

Included in the main folder will be pngs of the 2sigma stretch of the 0.4um band for:
1) original cloud position
2) translated cloud position via material entry
3) attempt at same translation via glist (in this case the cloud disappears)
Comment 1 Adam Goodenough 2016-09-13 16:57:08 EDT
Yes, this seems to be broken. The issue is a missing transform back into the local coordinate system when running the rad solver (and no easy way of getting there). I'm looking at ways to fix this right now.
Comment 2 Adam Goodenough 2016-09-14 09:52:53 EDT
The final issue here was that the mechanic used to maintain the local hit information (entry and exit points into the cloud grid in local coordinates) was not getting copied when being transferred into the global hit list (this is a rarely used mechanic and is really there to support these type of "black box" operations that we return to later). 

This should be fixed now after cleaning up the local hit information and transfer (verified translation of clouds).