Bug 1224 - Unable to set cloud geometry
Summary: Unable to set cloud geometry
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: Materials/Radiometry (show other bugs)
Version: 4.7.1-release
Hardware: Intel x86-64 Other
: P5 normal
Assignee: Adam Goodenough
URL:
Depends on:
Blocks:
 
Reported: 2016-06-28 17:56 EDT by Jeff Dank
Modified: 2016-07-21 13:42 EDT (History)
0 users

See Also:


Attachments
Files to reproduce the bug (5.10 KB, application/x-compressed-tar)
2016-06-28 17:56 EDT, Jeff Dank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Dank 2016-06-28 17:56:17 EDT
Created attachment 384 [details]
Files to reproduce the bug

I "think" I have all the material IDs set properly... but I can not get around this error.

Do you have ideas how I can get around this one for now?

I've attached all files to recreate this bug:

Material: cucc (ID/Label = 2, index = 2)
Bulk Optical Properties:

Reading voxelized cloud concentrations...done
Reading spectral specific absorption coefficient data...done
Reading spectral specific scattering coefficient data...done
Reading spectral scattering phase function data...done
Unable to set cloud geometry. 
   Unmatched material id: 2
  Verify that the atmospherics section of geometry has
  the matching material id (cloud_matid)
Comment 1 Jeff Dank 2016-06-29 12:50:21 EDT
I notice that I can get the plate to load in OR the cloud to load in. Not both at the same time.

I tried splitting them up and loading them in different .glists and I also tried loading the cloud in directly from the .scene file.

I'm only seeing that error if I try to load in both at the same time
Comment 2 Jeff Dank 2016-07-12 14:30:59 EDT
dirsig-4.6.2.15518 will load everything in fine. Perhaps something is breaking due to the new alpha-numeric capability
Comment 3 Adam Goodenough 2016-07-21 13:42:58 EDT
You are correct -- the issue was related to the new alpha-numeric capability. All of the correct code was in place, but unfortunately the call order for mapping the IDs to internal indexes was occurring after trying to set the cloud geometry.

This has been fixed and your test simulation seems to run. We'll get this out in the next release.