Bug 1187 - LidarPointing1 "with jitter, perfect knowledge" case isn't working right
Summary: LidarPointing1 "with jitter, perfect knowledge" case isn't working right
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: Demonstrations (show other bugs)
Version: 4.6.3-release
Hardware: Other Other
: P5 normal
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2015-09-10 16:11 EDT by Scott D. Brown
Modified: 2015-11-30 15:09 EST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott D. Brown 2015-09-10 16:11:43 EDT
If you run the "with jitter, perfect knowledge" case, the 3D scene target should reconstruct fairly well. Instead, the 3D point cloud is a mess.
Comment 1 Scott D. Brown 2015-09-10 16:15:29 EDT
The problem is specific to using the temporally uncorrelated jitter model.  The issue has been traced down to some changes that result in one jitter realization being used for imaging the focal plane and a different realization being stored in the BIN file. This is because the uncorrelated jitter model is not deterministic, and some performance improvements to eliminate a deep (and slow) cache resulted in not using the same values for the same query time.
Comment 2 Scott D. Brown 2015-10-28 09:23:45 EDT
Fixed in the 4.7.0 release cycle.