Bug 1128 - Problems resulting from with rays without date/time
Summary: Problems resulting from with rays without date/time
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: Geometry (show other bugs)
Version: 4.6.0-release
Hardware: Other Other
: P5 normal
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2014-11-14 08:49 EST by Michael Gartley
Modified: 2014-12-02 09:46 EST (History)
1 user (show)

See Also:


Attachments
offending simulation archive, run leosats.sim (221.06 KB, application/x-zip-compressed)
2014-11-14 08:49 EST, Michael Gartley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Gartley 2014-11-14 08:49:25 EST
Created attachment 354 [details]
offending simulation archive, run leosats.sim

attached an offending scene.. crashes for me *always* at 22.6% into the first frame of the simulation.

changing the ECF lookat location from:
  <x>0</x><y>0</y><z>0</z>
to anything else, such as:
  <x>1</x><y>1</y><z>0</z>

seems to get around the crash and let it run correctly. not sure why.
Comment 1 Scott D. Brown 2014-11-14 08:57:11 EST
I was able to reproduce the crash. I will dive into this one ASAP.
Comment 2 Scott D. Brown 2014-11-14 12:15:48 EST
So what you stumbled upon was actually a high-level bug related to setting the geolocation corner points in the ENVI header file. We ended up poking the scene with rays that had an invalid time and that caused the motion model to incorrectly position the scene objects. I am successfully running with a fix now.
Comment 3 Scott D. Brown 2014-12-02 09:46:51 EST
All of our testing seems to have confirmed that scenes with dynamic content are no longer corrupted by the probe rays that didn't have a valid date/time.