Bug 1108 - DIRSIG ignores more than 4 vertices per facet in an obj file
Summary: DIRSIG ignores more than 4 vertices per facet in an obj file
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: Geometry (show other bugs)
Version: 4.5.4-release
Hardware: All All
: P5 normal
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2014-07-15 12:38 EDT by Paul Romanczyk
Modified: 2014-10-07 08:46 EDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Romanczyk 2014-07-15 12:38:38 EDT
Prior to DIRSIG 4.6.0, wavefront obj files with more than 4 vertices per facet, will ignore the 5th and higher vertices. There will NOT be any warning or error. This may produce holes in the geometry.

Starting with DIRSIG 4.6.0, there is an error if an obj file contains too many vertices per facet.


One way to fix the geometry:
1. Open the obj file in Blender
2. Select the object(s) to convert
3. In edit mode, press Ctrl+T
4. Save modified obj file

See http://wiki.blender.org/index.php/Doc:2.4/Manual/Modeling/Meshes/Editing/Faces [accessed 2014-07-15]
Comment 1 Scott D. Brown 2014-09-22 14:22:02 EDT
Paul,
Somehow I missed you submit this one. Your wording is slightly confusing as to what you want. Yes, there is now an error reported if you have more than a 4 sided facet. I'm not sure if it ignored them before, or if it attempted to cut them into multiple triangles.

I guess the question is "What is the bug exactly?"  You don't like that it is an error now and would like it to be a warning?  Or you would like some other behavior?

As you pointed out, a quick Open/Close cycle in Blender, Meshlab, etc. will usually produce an OBJ with only 3 or 4 sided polygons.
Comment 2 Paul Romanczyk 2014-09-22 15:39:59 EDT
There really isn't a bug here (unless you in are using <4.6) where geometry is ignored. This was intended as a "bug" for documentation purposes in case someone else runs DIRSIG 4.6 or later and gets an error on a scene that did not have one in the earlier releases.
Comment 3 Scott D. Brown 2014-10-07 08:46:33 EDT
Closing this bug because unlike earlier versions, 4.6 and later releases issue an error for polygons (facets) with more than 4 vertexes.