Bug 1057 - Blender plug-in does not work after Blender2.65A
Summary: Blender plug-in does not work after Blender2.65A
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: Utilities (show other bugs)
Version: 4.5.1-release
Hardware: Macintosh Intel Other
: P5 minor
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2013-08-16 15:06 EDT by Paul Romanczyk
Modified: 2013-10-14 16:06 EDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Romanczyk 2013-08-16 15:06:00 EDT
The Blender (2.5x) plug-in does not work after Blender 2.65A (last working version). 

Blender 2.66-2.67B will allow for installation, but the radio button to activate the add-on is not clickable. 

Blender 2.68-2.68A will allow for installation, but throws an error when activating:

Traceback (most recent call last):
  File "/Applications/Blender/blender.app/Contents/MacOS/2.68/scripts/modules/addon_utils.py", line 294, in enable mod = __import__(module_name)
  File "~/Library/Application Support/Blender/2.68/scripts/addons/dirsig_utils.py", line 1147, in <module> def import_dirsig_obj(filename, scn=bpy.context.scene):
AttributeError: '_RestrictContext' object has no attribute 'scene'
Comment 1 Scott D. Brown 2013-10-14 09:40:26 EDT
I think Mike and/or Chris was looking for updates to the plugins for the newer versions of Blender, too.
Comment 2 Scott D. Brown 2013-10-14 16:06:36 EDT
Andy Scott sent me an updated plugin that works on my 2.62 build just fine.  We will bundle it into the 4.5.2 release.