Bug 1017 - The correlated jitter editor needs many improvements
Summary: The correlated jitter editor needs many improvements
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: dirsig_edit (show other bugs)
Version: 4.5.0-release
Hardware: Other Other
: P5 normal
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2013-03-22 09:12 EDT by Scott D. Brown
Modified: 2013-04-15 08:07 EDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott D. Brown 2013-03-22 09:12:13 EDT
To reproduce:
* Select the "Correlated Jitter" model somewhere (platform motion, mount, etc.)
* Click the "Edit" button
* Notice how both the "Add" and "Delete" buttons are disabled.  We need the "Add" button to be enabled so the user can add some data.  Otherwise the right-click "Import" mechanism is their only option.
Comment 1 Scott D. Brown 2013-03-22 09:15:34 EDT
Furthermore when correctly enabled, the "Add Entry" and "Delete Entry" actions do not appear to do anything.
Comment 2 Scott D. Brown 2013-03-22 09:19:54 EDT
Other things to improve:
* The initial plot window is a mess because the initial ranges are poor.
* The "import file" mechanism doesn't user the more robust text import wizard.
Comment 3 Scott D. Brown 2013-03-25 10:00:18 EDT
QDGraph needs an "impulse" style to plot this data correctly.
Comment 4 Scott D. Brown 2013-04-15 08:07:20 EDT
Make sure the auto-scaling gets reset if the user deletes all the entries.