Bug 1010 - Viewing a weather file erases the path from the Atmospheric Conditions Editor
Summary: Viewing a weather file erases the path from the Atmospheric Conditions Editor
Status: RESOLVED FIXED
Alias: None
Product: DIRSIG4
Classification: Unclassified
Component: dirsig_edit (show other bugs)
Version: 4.5.0-release
Hardware: Other Other
: P5 normal
Assignee: Scott D. Brown
URL:
Depends on:
Blocks:
 
Reported: 2013-03-19 22:25 EDT by Scott D. Brown
Modified: 2013-03-28 16:54 EDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott D. Brown 2013-03-19 22:25:36 EDT
Steps to reproduce the issue:
* Open the Atmospheric Editor
* Browse and select a weather file
* Notice that the weather filename path reflects the selected file
* Click the "View Weather Entries" button
* Close the weather entry dialog window
* Notice how the weather filename path is now empty
Comment 1 Scott D. Brown 2013-03-22 09:08:29 EDT
This is because the weather file viewer can also generate a new weather file, so it would return the name of that new file.  However, if the user just views the data, we returned an empty filename which would overwrite the existing filename.

We added a check to see if that returned filename is not empty (which would be the case when you generate data), and if it is not empty we update the filename.  Otherwise, we stick with the old filename.